Saltar al contenido
Closer Marketing

WordPress Gutenberg 10.2 que causa errores fatales

Los editores de WordPress están descubriendo que Gutenberg 10.2 (lanzado el 17 de marzo de 2021) está causando «errores fatales» debido a un problema de incompatibilidad con WordPress. Un editor sugirió que las actualizaciones automáticas de Gutenberg deberían hacer una verificación de compatibilidad y activar una advertencia si existe la incompatibilidad.

WordPress Gutenberg

Gutenberg es un editor visual de sitios de WordPress que representa una desviación radical de la forma en que los sitios web se construyeron de forma nativa dentro del núcleo de WordPress.

Permite a los editores crear sitios utilizando la interfaz gráfica de usuario de bloques. Por ejemplo, una página web se puede visualizar como bloques que representan la parte superior de la página (encabezado), el área de contenido, la barra lateral, etc.

Gutenberg aún no ha terminado, la capacidad de edición completa del sitio aún está en camino. Así que, naturalmente, como una tecnología aún no madura, los errores son de esperar, si no es que se esperan.

Error fatal de Gutenberg 10.2

Un miembro del grupo de Facebook de WordPress avanzado inició una discusión para documentar un error fatal encontrado al actualizar a Gutenberg 10.2.

La publicación declaró que el error fatal se manifestó en la versión 5.6 de WordPress. También se señaló que una publicación de GitHub sobre el error señaló que Gutenberg 10.2 tampoco es compatible con WP 5.5.

Cronología de lanzamiento de WordPress y Gutenberg

WordPress 5.7 fue lanzado el 9 de marzo de 2021.

El editor del sitio Gutenberg 10.2 se lanzó poco más de una semana después, el 17 de marzo de 2021.

Los editores de sitios de Gutenberg que actualizaron a WordPress 5.7 y luego actualizaron a Gutenberg 10.2 no deberían ver este error.

Sin embargo, los editores que actualizaron a Gutenberg 10.2 pero no a WordPress en sí pueden experimentar el error fatal.

El error fatal es particularmente probable que le ocurra a los editores que configuran sus instalaciones de Gutenberg para que se actualicen automáticamente (actualización automática) pero no están configurados para actualizar automáticamente WordPress.

Se observó un error en los foros oficiales de soporte de WordPress de Gutenberg, pero en el momento de escribir este artículo no había seguimiento.

El problema de la falla fatal también se documentó en la página oficial de Gutenberg GitHub.

Del informe de GitHub:

“Después de actualizar a la versión 10.2.0, recibí un correo electrónico sobre un problema técnico con el complemento:

Se produjo un error de tipo E_ERROR en la línea 59 del archivo … Pude desactivar el complemento a través de ftp. Ahora no quiero activarlo hasta que sepa que esto se ha solucionado «.

Otra persona publicó que notó lo mismo y publicó una captura de pantalla:

Captura de pantalla del error fatal de WordPress Gutenberg

El usuario que publicó la captura de pantalla siguió con:

“Estaba ejecutando WordPress 5.6. Después de la actualización a 5.7, todo comenzó a funcionar como se esperaba «.

La persona que inició la publicación original de GitHub afirmó que este también era su problema.

“Gracias por informarme sobre 5.7. Tampoco había actualizado WP, ahora puedo reactivar Gutenberg «.

Gutenberg 10.2 incompatible con versiones anteriores de WordPress

Otro informe de GitHub Gutenberg destacó que Gutenberg 10.2 causó errores fatales en versiones anteriores de WordPress.

Un editor que usa la versión 5.5.3 de WordPress también informó de un error fatal que provocó un bloqueo.

La persona que informó el problema confirmó que era específico de Gutenberg 10.2, y afirmó:

“Desactivé el complemento Gutenberg 10.2.0. Cuando intenté reactivar el complemento, volvió el error fatal.

Fatal error: Uncaught Error: Class 'WP_Block_Supports' not found in..."

La persona hizo una observación útil y sugirió que Gutenberg 10.2 no debería poder actualizarse (o actualizarse automáticamente) en versiones de WordPress inferiores a WP 5.7.

“No debería ser posible actualizar automáticamente el complemento de Gutenberg en un sitio de WP más antiguo. Como resultado, parece crear un error fatal. Ya que puede haber muchos sitios que se encuentren con este problema «.

¡Esa es una buena solución al problema! Si existe una incompatibilidad conocida entre Gutenberg 10.2 y versiones anteriores de WordPress, entonces tiene sentido que las actualizaciones automáticas en esas situaciones se detengan y generen una advertencia de incompatibilidad.

Los usuarios del editor del sitio de Gutenberg que publican con una versión de WordPress anterior a WP 5.7 pueden considerar prudente actualizar a la última versión antes de actualizar a Gutenberg 10.2.

Deja una respuesta

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *

Esta web utiliza cookies, puedes ver la política de cookies aquí.    Más información
Privacidad